News

5.0.5 - 2016-12-20

改良

  • test-unit-activesupport 1.0.8 以降を必須にした。

5.0.4 - 2016-12-20

修正

  • Rails 4 で動かなくなっていたのを修正。 [GitHub#11][Akira Matsudaさんがパッチ提供]

感謝

  • Akira Matsuda

5.0.3 - 2016-12-19

改良

  • ドキュメントファイルのフォーマットをTextileからMarkdownにした。 [GitHub#10] [takiy33さんがパッチ提供]

  • file_fixture をサポート。

感謝

  • takiy33

5.0.2 - 2016-06-28

改良

  • Active Recordを使用していないRailsアプリでも動作するようにした。 [GitHub#8][Akira Matsudaさんがパッチ提供]

修正

  • テストが失敗しているのを修正。[Shita Koyanagiさんが報告]

感謝

  • Shita Koyanagi

  • Akira Matsuda

5.0.1 - 2016-02-27

修正

  • gemに足りないファイルを追加。 [GitHub#7] [y-yagiさんがパッチ提供]

感謝

  • y-yagi

5.0.0 - 2016-01-18

Rails 5 のサポートリリースです。

改良

  • Rails 5 をサポートした。
  • Rails 4 以降だけをサポートするようにした。 [GitHub#5][Charles Lowellさんがパッチ提供]

感謝

  • Charles Lowell

1.0.4 - 2014-09-07

バグフィックスリリースです。

修正

  • Test::Unit でテストするための正しいクラスを拡張するようにしました。 以前は Test::Unit::TestCase を拡張していましたが、 今は ActiveSupport::TestCase を拡張しています。 ActiveSupport::TestCase ( TestUnit::TestCase ではなく) は ActionController::TestCase (コントローラテスト用) や ActionDispatch::IntegrationTest (インテグレーションテスト用) に継承されているからです。

1.0.3 - 2014-09-04

改良

  • Rails4.0.0をサポート。 このバージョン意向。test-unit-railsはtest-unit-active-supportの1.0.2以上を必須とします。 このバージョンで、Rails3.2.16以前をサポートしなくなりました。 もし3.2.16以前のRailsで使用したい場合は、test-unit-railsの1.0.2をお使いください。

1.0.2 - 2012-07-05

改良

Bundler 1.2.0.pre.1対応。 [GitHub#1] [Michael D.W. Prendergastさんが報告]

感謝

  • Michael D.W. Prendergastさん

1.0.1 - 2012-06-03

改良

ActiveSupport関連のコードをtest-unit-activesupport gemに抽出してそのgemを使うようにした。

1.0.0 - 2012-1-2

最初のリリース!